郑州股票分析联盟

股价预测指标,买卖出神入化

股票量化研究所2021-01-08 10:34:31


此指标为电脑版指标,手机版未测试能否通用;复制代码的时候复制全,最好是电脑上下载一个微信,这样复制会更方便也不会缺胳膊少腿的造成测试通不过,有参数的指标最好参数写上。源码分享,方便大家继续优化。一般不接指标代写,除非你思路有多次成功的案例


用法说明

预测当天最低价,预测当天最高价

指标源码
1、如果高开2%以上,可直

 N:=27;PP:=0.03;
 AAA2:=SUM(IF( CLOSE>REF(CLOSE,1),VOL*C,0),0);
 AAA3:=SUM(IF( CLOSE<REF(CLOSE,1),VOL*C,0),0);
 AAA4:=SUM(IF( CLOSE=REF(CLOSE,1),VOL*C,0),0);
 BB1:=0;
 B1万元:=DVOL*DCLOSE/100;
 B1差:=B1万元-REF(B1万元,1);
 B2万元:=DVOL*DCLOSE/100;
 B2比:=B2万元/REF(B2万元,1);
净流入万元:=(AAA2-AAA3-0.5*AAA4);
 PM:=MA(净流入万元,1);
 PMA:=PM/REF(PM,1)>1;
 PMB:=REF(PMA,1)<1 AND PMA;
数字:(EMA(MA(B1万元,2),2))/100000,COLORYELLOW,NODRAW;
二日比:=数字/REF(数字,1);
选股:PMB AND 数字>REF(数字,1) AND 二日比>1,COLORRED,NODRAW;
 MA5:MA(C,5);MA10:MA(C,10);MA30:MA(C,30);
 DRAWNUMBER(选股=1 ,L,数字),COLORYELLOW;
 DRAWICON(选股,L*0.975,1);
A1:=REF(O,1);
 A2:=ABS((REF(C,1)-A1)/A1);
 A3:=ABS((REF(H,1)-A1)/A1);
 A4:=ABS((REF(L,1)-A1)/A1);
 B1:=ABS((A2+A3+A4)/3);
 B2:=O*B1;
预测低一:=O-B2;
预测高一:=O+B2;
今日保护价:(REF(C,2)+REF(C,1)+O)/3 ,COLOR4080FF,NODRAW;
开盘价1:=OPEN;
开盘价2:=REF(OPEN,1);
最高价1:=HIGH;
最高价2:=REF(HIGH,1);
最低价1:=LOW;
最低价2:=REF(LOW,1);
收盘价1:=CLOSE;
收盘价2:=REF(CLOSE,1);
 AA:=最高价2;
 BB:=最低价2;
 CC:=开盘价2;
 DD:=收盘价2;
 EE:=(AA+BB+CC+2*DD)/5;
 AAA:=EE+(AA-BB);
 BBB:=2*EE-BB;
 CCC:=2*EE-AA;
 DDD:=EE-(AA-BB);
上升突破价:=AAA;
上升阻力价:=BBB;
下跌支撑价:=CCC;
下跌反转价:=DDD;
 EEE:=(EE+上升突破价+上升阻力价+下跌支撑价+下跌反转价)/5;
心理价:=EEE;
 FFF:=(EEE+开盘价1)/2;
 GGG:=(预测低一+FFF)/2;
预测低二:=GGG;
预测高二:=MA(REF(HIGH,1)/REF(CLOSE,2),N)*REF(CLOSE,1);
 DRAWTEXT_FIX(1,0.04,0.15,0,'预测低一:'),COLORYELLOW;
 DRAWNUMBER_FIX(1,0.10,0.15,0,CONST(预测低一)),COLORYELLOW;
 DRAWTEXT_FIX(1,0.15,0.15,0,'元'),COLORYELLOW,LINETHICK1;
 DRAWTEXT_FIX(1,0.04,0.20,0,'预测高一:'),COLORFFFFFF;
 DRAWNUMBER_FIX(1,0.10,0.20,0,CONST(预测高一)),COLORFFFFFF;
 DRAWTEXT_FIX(1,0.15,0.20,0,'元'),COLORFFFFFF,LINETHICK1;
 DRAWTEXT_FIX(1,0.18,0.15,0,'预测低二:'),COLORYELLOW;
 DRAWNUMBER_FIX(1,0.24,0.15,0,CONST(预测低二)),COLORYELLOW;
 DRAWTEXT_FIX(1,0.29,0.15,0,'元'),COLORYELLOW,LINETHICK1;
 DRAWTEXT_FIX(1,0.18,0.20,0,'预测高二:'),COLORFFFFFF;
 DRAWNUMBER_FIX(1,0.24,0.20,0,CONST(预测高二)),COLORFFFFFF;
 DRAWTEXT_FIX(1,0.29,0.20,0,'元'),COLORFFFFFF,LINETHICK1;
买回价:=预测低二*1.015;
卖出价:=买回价*(1+PP);

DRAWTEXT_FIX(1,0.04,0.10,0,'卖出价:'),COLOR8080FF,LINETHICK1;
 DRAWNUMBER_FIX(1,0.10,0.10,0,CONST(卖出价)),COLOR8080FF;
 DRAWTEXT_FIX(1,0.15,0.10,0,'元'),COLOR8080FF,LINETHICK1;
 DRAWTEXT_FIX(1,0.18,0.10,0,'买回价:'),COLOR8080FF,LINETHICK1;
 DRAWNUMBER_FIX(1,0.24,0.10,0,CONST(买回价)),COLOR8080FF;
 DRAWTEXT_FIX(1,0.29,0.10,0,'元'),COLOR8080FF,LINETHICK1;
 DRAWTEXT_FIX(1,0.01,0.02,0,'★

=========================================== ★'),COLORRED;
 DRAWTEXT_FIX(1,0.15,0.05,0,'T+1 操 作'),COLORFFFFFF;
 DRAWTEXT_FIX(1,0.01,0.08,0,'操 '),COLOR0000FF;
 DRAWTEXT_FIX(1,0.01,0.12,0,'盘 '),COLOR0000FF;
 DRAWTEXT_FIX(1,0.01,0.16,0,'铁'),COLOR0000FF;
 DRAWTEXT_FIX(1,0.01,0.20,0,'律'),COLOR0000FF;
 DRAWTEXT_FIX(1,0.32,0.08,0,'坚 '),COLOR0000FF;
 DRAWTEXT_FIX(1,0.32,0.12,0,'决 '),COLOR0000FF;
 DRAWTEXT_FIX(1,0.32,0.16,0,'执'),COLOR0000FF;
 DRAWTEXT_FIX(1,0.32,0.20,0,'行'),COLOR0000FF;
 DRAWTEXT_FIX(1,0.01,0.24,0,'★

=========================================== ★'),COLORRED;


 STICKLINE(C>=O,C,O,3.4,0),COLOR0000AA;
 STICKLINE(C>=O,C,O,3.0,0),COLOR0000BB ;
 STICKLINE(C>=O,C,O,2.4,0),COLOR0000CC;
 STICKLINE(C>=O,C,O,2.0,0),COLOR0000DD ;
 STICKLINE(C>=O,C,O,1.6,0),COLOR0000EE;
 STICKLINE(C>=O,C,O,1.2,0),COLOR0000FF;
 STICKLINE(C>=O,C,O,0.6,0),COLOR0000FF;
 STICKLINE(C>=O,H,L,0,0),COLORRED;
 STICKLINE(C<=O,C,O,3.4,0),COLORAAAA00;
 STICKLINE(C<=O,C,O,3.0,0),COLORBBBB00;
 STICKLINE(C<=O,C,O,2.4,0),COLORCCCC00;
 STICKLINE(C<=O,C,O,2.0,0),COLORDDDD00;
 STICKLINE(C<=O,C,O,1.6,0),COLOREEEE00;
 STICKLINE(C<=O,C,O,1.2,0),COLORFFFF00;
 STICKLINE(C<=O,C,O,0.6,0),COLORFFFF00;
 STICKLINE(C<=O,H,L,0,0),COLORFFFF00;





我的炒股心法
☟  ☟  ☟

量化买盘卖盘情绪筹码

❶ VX:股票量化研究所

❸ 长按二维码,加关注

 提供 大盘/个股交流/指标源码/经验战法等精彩内容