郑州股票分析联盟

通达信股票软件指标自用的薛斯通道指标源码

翔博软件工作室2022-03-25 09:30:33

点击上面免费订阅

问:怎么每天都能免费收到这种好指标呢?

答:只需点上边翔博软件工作室关注,加微信:396950280免费领取!

公式源码:

AA:=MA((2*CLOSE+HIGH+LOW)/4,5); 

CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20); 

DD:=DMA(CLOSE,CC); 

通道A:=AA*N/100; 

通道B:=AA*(200-N)/100; 

通道C:=(1+M/100)*DD,COLOR6B8E23; 

通道D:=(1-M/100)*DD;

DRAWBAND(通道C,RGB(100,149,237),通道D,RGB(0,100,0));

DRAWBAND(通道A,RGB(        238,130,238),通道B,RGB(0,100,0));

通道1:AA*N/100,LINETHICK2; 

通道2:AA*(200-N)/100,LINETHICK2; 

{STICKLINE(通道1-通道2>0,通道1,通道2,1,-1),COLORBLUE;}

通道3:(1+M/100)*DD,COLOR6B8E23,LINETHICK2; 

通道4:(1-M/100)*DD,LINETHICK2;

{主趋势线:EMA(EMA(C,10),10),COLORBLUE,LINETHICK2;

B:=主趋势线<REF(主趋势线,1);

IF(B-1,主趋势线,DRAWNULL)COLORRED,LINETHICK2;}

主趋势线:EMA(EMA(C,10),10),COLORRED,LINETHICK2;

B:=主趋势线>REF(主趋势线,1);

{IF(B-1,主趋势线,DRAWNULL)COLORBLUE,LINETHICK2;

操盘线:EMA(EMA(C,5),5),COLORRED,LINETHICK2;

Y:=操盘线>REF(操盘线,1);

IF(Y-1,操盘线,DRAWNULL)COLORGREEN,LINETHICK2;}

ZF:=STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(DYBLOCK,' '),HYBLOCK),' '),GNBLOCK),' '),FGBLOCK);

DRAWTEXT_FIX(ISLASTBAR,0,0,0,ZF),COLORYELLOW;

DIF:=EMA(CLOSE,9)-EMA(CLOSE,21);

DEA:=EMA(DIF,5);

MACD:=(DIF-DEA)*2;

吸:XLPL.NOTEXT吸,NODRAW,COLORLIRED;

拉:XLPL.NOTEXT拉,NODRAW,COLORRED;

派:XLPL.NOTEXT派,NODRAW,COLORGREEN;

落:XLPL.NOTEXT落,NODRAW,COLORWHITE;

AAW:=IF(吸!=DRAWNULL,DIF,DRAWNULL),COLORLIRED,LINETHICK2;

BBW:=IF(拉!=DRAWNULL,DIF,DRAWNULL),COLORRED,LINETHICK2;

CCW:=IF(派!=DRAWNULL,DIF,DRAWNULL),COLORGREEN,LINETHICK2;

DDW:=IF(落!=DRAWNULL,DIF,DRAWNULL),COLORWHITE,LINETHICK2;

STICKLINE(AAW,LOW,HIGH,0,0),COLORLIRED;

STICKLINE(AAW,C,O,3,1),COLORLIRED;

STICKLINE(BBW,LOW,HIGH,0,0),COLORRED;

STICKLINE(BBW ,C,O,3,1),COLORRED;

STICKLINE(CCW,LOW,HIGH,0,0),COLORGREEN; 

STICKLINE(CCW,C,O,3,1)COLORGREEN;

STICKLINE(DDW,LOW,HIGH,0,0),COLORWHITE;

STICKLINE(DDW,C,O,3,1),COLORWHITE;

DRAWTEXT("KDJ.J"-REF("KDJ.J",1)>30 AND C/REF(C,1)>1.043 AND "MACD.MACD">0 

AND EXPMA(C,12)>EXPMA(C,50),L*0.995,'起爆'),COLORWHITE;

V1:=EMA(CLOSE,5);

V2:=EMA(EMA(CLOSE,90)*1.01,10);

DRAWTEXT(CROSS(V1,V2),V1+0.05,'牛起步'),COLOR00FF00;

VAR1:=LLV(LOW,21);

VAR2:=HHV(HIGH,21);

AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);

AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);

AB:=CROSS(AK1,AK);

DRAWTEXT((AB = 1),(LOW * 0.99),'○牛窝'),COLORYELLOW;

AA1:=AMOUNT/V;

BB1:=L<AA1*0.9;

CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;

DD1:=L<MA(C,5)*0.921;

EE1:=V<MA(V,5)*1.5;

老鼠仓:=BB1 AND CC1 AND DD1 AND EE1,LINETHICK0,COLOR0099FF;

DRAWTEXT(老鼠仓,L*0.99,'老鼠仓'),COLOR0099FF;

VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);

VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);

DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.93),'★大胆搏 '),COLOR00FFFF;

DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.99000001),'★加仓 '),COLOR00FFFF;

A1AA:=9;

A2AA:=(REF(CLOSE,A1AA+1)<CLOSE);

DRAWTEXT(FILTER((A2AA>-0.5),84),(HIGH)*(1.05),'小心变盘'),COLORFFFFFF;

VAR6:=REF(C,1);

VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;

DRAWTEXT(CROSS(82,VAR7),H*1.01,'逃顶'),COLORYELLOW;

通达信手机版公式导入方法

一、进入公式编辑器界面

1、点击进入公式编辑器

2、点击指标编辑,选择新建指标

二、按照上面所发布的指标公式源码,进行复制填写

1、填写公式名称、描述、指标说明,填好后点左上角公式按键

2、然后点公式,对公式源码进行复制黏贴

3、填好后,点击测试公式,通过后点击保存,公式编辑就结束了

三、进入主界面选择公式,即可使用。

1、点击进入指标选择

2、在指标选择中的用户指标栏,根据所需选择自编公式

特别提示:

选股预警指标编写 ,不同主流行情软件间指标转换。 请联系微信:396950280

一个聚百万原创指标公式圈子

原创价值分享公众号

ID:yungongshi

点击“阅读原文”,进入翔博微商城